You are not logged in or registered. Please login or register to use the full functionality of this board...
Hello There, Guest!

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Light elegance problems
#26
I had the same thing happen... it was weird... used the product for a long time and then, was not getting the same adhesion... pulled out the instructions and went over everything to see if I had developed some bad habit...
I still use the lamp and when it goes will buy another
it has outlived everything else and the angle of the bulbs give the absolute best coverage
I did something no one recommends, I tried some others for a base coat, worked... so I still use the builders and colors... etc
 Reply

Possibly Related Threads...
Thread
Author
  /  
Last Post
Replies: 8
Views: 5,267
06-05-2017, 02:21 AM
Last Postcosmobeauty
Replies: 4
Views: 6,362
01-07-2017, 10:31 PM
Last PostMary C
Replies: 1
Views: 1,402
04-07-2016, 11:58 AM
Last PostNailzOnLine
Replies: 5
Views: 2,584
12-07-2015, 11:06 AM
Last Postjb100680
Replies: 4
Views: 2,854
07-16-2015, 08:57 PM
Last PostBLINGINABOX
Replies: 1
Views: 1,581
07-15-2015, 09:10 PM
Last Postscotchtapeandrhinestones
Replies: 5
Views: 2,974
07-05-2015, 12:29 PM
Last PostPrecisionNails
Replies: 2
Views: 2,066
07-05-2015, 12:23 PM
Last Postjennie
Replies: 7
Views: 4,505
05-17-2015, 11:23 PM
Last Post*pixie*
Replies: 2
Views: 2,157
01-14-2014, 11:57 AM
Last Postdini

 
Forum Jump:


Users browsing this thread: 1 Guest(s)